Tuesday, April 17, 2012

Update on Bell Turbo Hub performance issues

Well, believe it or not it seems that Bell actually does at least try to solve network performance problems. Sometime after I started calling them on a regular basis I seemed to notice some improvements in the network performance. The really long (3 to 10 seconds) delays in connectivity seem to happen much less often, however transfer speeds were continuing to show very inconsistent results which were sometimes simply pathetic (0.1 Mbps). My guess is they either added some hardware to the local tower or tweaked the settings on their systems to provide better response times. One of their techies at one point told me that they can also tweak the antennae arrays on the tower to adjust the signal strength in different directions.

Anyway, at some point they said that the network people have done their testing and the signal strength in my area was ok. So then they started blaming the problem on my hub. They wanted me to take the hub into a Bell store for testing or to take it to a different location to test. Well, I told them that the results are so inconsistent and the conditions here would be nothing like the conditions elsewhere (e.g. internal vs external antennae) that such a test would be useless. Not to mention the fact that I don't have time to do this testing on their behalf. I also pointed out that they are the ones claiming that the problem was with my hub (I still think the hub has nothing to do with these problems) and so they agreed to send me a new router to replace my existing one.

Well, after switching to the new hub a few days ago I still can't really notice much difference. However, I was able to Skype into a conference call that lasted over an hour with only a few drop-outs of more than a few seconds. This is a big improvement from when I started and Skype was completely unusable. My guess is that this was due to tweaking done to their network hardware.

So if you're having problems with your Bell connectivity call them and get them to open a support ticket. Each time you call back give them the ticket number and tell them you want to know what progress has been made. Be polite but persistent. Remind them that you're paying for what they advertise.

If I continue to get less than 1 Mbps download speeds then I will continue to complain that I'm paying for high speed but I'm not getting it. Right now it's hit or miss and things like watching YouTube videos can still be a very frustrating experience.

1 comment:

Anonymous said...

Recently over the past 2 weeks we have been having the same issues with ours.Very inconsistent speeds and many drops or DSN server unresolved issues. Called many times opened a ticket, the tech staff tell me my signal has switched to a more distant tower and signal is therefore much interference and delays which explain the low speed tests at .2 Meg's per sec download.For seven months it was acceptable and now this, it's pathetic, I explain to them that they have changed my service to next to none, but customer service wants to hold me to a cancelation fee of $280 ( I plan to install Satilite ) .... Pay for service you are not getting , something wrong with that ,,,, !, The contract is iron clad unfortunately .... Only out to suspend service for extended vacation for max 6 months at $15 per month then cancel .... No competitor I'm afraid they got us ... Some service commitment ..... Asked them to put me back on previous tower, said cant be done ... Network selects that ... Go figure ?????? Fred